Author Topic: (Help) Error with packaging map  (Read 3107 times)

RedRookLord

  • Posts: 38
  • Dungeon Crafter
    • View Profile
(Help) Error with packaging map
« on: January 04, 2014, 03:34:13 PM »
Ok, so these problems have been around awhile...but I think the solutions are all out of date and I can't find the solution anywhere in the forums, on youtube, on the wiki, or anywhere for that matter.

So when I try and test the map through the editor, it gives me an error and I don't know how to fix it and I haven't found an out of date answer either. I've tried spawning with a camera, I've tried spawning with a spawn point, niether work.

So I've tried the old way of making a folder and running the folder through the game, but that obviously doesn't work. The folder doesn't show up.

The last thing I tried was packaging the .xml file through the level packer. I tried doing just the .xml and I tried .xml in a folder. That doesn't work. I'm guessing I need the extra content in the folder for it to work, but the problem now is my copy of hammerwatch didn't come with an example folder.

So now that I've explained what I've tried...could somebody explain to me how they make their maps at this current date and how they test it? Sorry if there's an obvious answer somewhere, but I've looked for a couple hours now and I haven't seen it.
« Last Edit: January 04, 2014, 03:36:35 PM by RedRookLord »

Hipshot

  • Developer
  • Posts: 453
  • Level Designer
    • View Profile
Re: (Help) Error with packaging map
« Reply #1 on: January 04, 2014, 04:22:51 PM »

RedRookLord

  • Posts: 38
  • Dungeon Crafter
    • View Profile
Re: (Help) Error with packaging map
« Reply #2 on: January 04, 2014, 05:30:24 PM »
No, I haven't, but when I tried it, the level packer crashed again when I tried to package it. I created the 2 new .xml files and I have my map with them all in one folder. I tried dragging the folder onto the level packer and..it freezes.

Is there something I'm missing?

I'll attach a .zip with the folder in it.

RedRookLord

  • Posts: 38
  • Dungeon Crafter
    • View Profile
Re: (Help) Error with packaging map
« Reply #3 on: January 05, 2014, 03:02:50 PM »
Thank goodness I finally got it. It was several errors on my end. I slept on it and realized I may not have typed in the right text since code tends to have that problem, so I checked it out and realized that "level" was supposed to be typed "levels".

Sorry for the confusion. I'm very happy now though.