Author Topic: Editor and Linux... waa  (Read 2364 times)


  • Posts: 96
  • Faggot Crusher.
    • View Profile
Editor and Linux... waa
« on: January 12, 2014, 03:35:45 PM »
I was told that Hammerwatch wasn't tested on linux. My game works completely fine, but when it comes to the editor. . , oh dear.
I am not sure if it is my fault, i think i am doing everything right, as i know what i am doing.

So i load hammerwatch editor, with mono, it loads fine, and i can use it, when i run the map, while having all the correct xml's, it loads a black screen, and then it closes, and apparently it is open as a process, and on the side, but i can't open it. I gave my map folder to my friend, and he was able to open and run the map, so i don't think anything is wrong with the map, is there suppose to be another way to test the map?

I also don't think, anything custom works. I have successfully made custom music, and a couple of doodads, textures, mobs, which in in my levels folder. The editor doesn't load this as all, so i can't make anything that is custom. Again, i gave my folder to my friends, and all the custom stuff worked and loaded for him, so there must be something wrong with the linux version.

It will probably be hard to fix anything for linux, but please can you guys try, or help me?

I have given on on creating maps as a whole, because i can't do anything, so please fix it :DDD.

Thanks if you read this far.


  • Posts: 44
  • KlokWorkz main artist and level designer.
    • View Profile
Re: Editor and Linux... waa
« Reply #1 on: July 06, 2014, 03:03:30 AM »
at least you got mono working :O
I would really love a editor for linux and mac too:P