Author Topic: Editor test crash?  (Read 1414 times)

turtleband

  • Posts: 3
  • Rookie Level Editor
    • View Profile
Editor test crash?
« on: July 21, 2015, 06:07:36 AM »
Recently, when I've been trying to launch a certain test level, the debug starts up, but 5 seconds after it's loaded, it stops responding and crashes. Help? Level included below.
« Last Edit: July 21, 2015, 06:29:38 AM by turtleband »
Please stay in my healing beam, you are going to waste all of our lives.

kovo

  • Posts: 2
  • Maggot Crusher.
    • View Profile
Re: Editor test crash?
« Reply #1 on: May 18, 2016, 12:36:14 PM »
I have same problems...

rpc190

  • Posts: 44
  • Map Maker
    • View Profile
Re: Editor test crash?
« Reply #2 on: May 18, 2016, 09:07:26 PM »
Ah the power of necro posts! Kovo if you want to link your map here I can take a look at it.

turtleband if you happen to still be stuck on that map and be browsing this forum a year later I have a solution for you that I wrote up before I noticed how old this thread is:

Spoiler for Hiden:
turtleband, the crash on your map is caused by the projectile shooters in the middle of the map. You have them linked to retrigger the TimerTriggers which creates an infinite loop. TimerTriggers go off by themselves on the set interval. If you remove the links between the three projectile shooters it should run fine.

Looking at other parts of your scripts it looks like you might not 100% understand how linking works. If you link two scripts (ctrl+alt+left click) if causes the original node to run the other node, this does not only apply to trigger scripts. Your idea of the companion is very interesting, keep up the good work.