Author Topic: Debug Assertion failure bug [SOLVED (?)]  (Read 131 times)

Aversal

  • Posts: 3
  • Maggot Crusher.
    • View Profile
Debug Assertion failure bug [SOLVED (?)]
« on: November 16, 2017, 04:40:10 PM »
So I've been playing this game for years now, but suddenly yesterday I encountered a weird error.
The game froze the moment I exit it, and on all the subsequent launches this shows up about ten seconds later:

Spoiler for Hiden:

The game doesn't respond and eventually crashes no matter which option you choose.
I've tried reinstalling the game, verifying file integrity via Steam, tending to the error reports in the game files etc. but nothing works.
The game played fine once after my computer performed a hard drive checkup on boot, but again, the first time I closed the game afterwards it froze and I went back to square one.

Anyone got the same problem? Any idea if it'll never work again? And yes, I tried the OpenAL solution too.
Thanks.
« Last Edit: November 25, 2017, 12:51:19 PM by Aversal »

Aversal

  • Posts: 3
  • Maggot Crusher.
    • View Profile
Re: Debug Assertion failure bug (?)
« Reply #1 on: November 19, 2017, 12:29:30 AM »
I'm not sure if people have done this before reportedly, but I did find a solution that worked, at least for me.

(For context, I'm using Windows 7)
So first I opened the control panel and clicked on 'locate and fix problems' (I don't know what it's called exactly in English versions).
Then I clicked on 'Find problems related to the processing power', or again, whatever it's translated to/from.
In the troubleshooting process I was given the option to prevent some kind of rundll program from starting on launch, and I decided to do so.
I can't really provide details regarding that, since I can't redo or backtrack the troubleshooting again as it considers the problem solved.

Afterwards Hammerwatch didn't crash anymore, but it reduced the screen to a limited amount of colors, and as a result everything looked dithered and every icon was from a decade-or-more-older version of Windows.
To fix this, I opened the properties-window for the Hammerwatch.exe file and opened the 'compatibility mode' tab.
There was a checked box, which said the application is opened in compatibility mode with Win7 being the target version.
I only had to uncheck the 'restrict to 256 screen colors' box and then the game ran all fine.

I sure hope this is a fix that everyone can use, since this problem had been reported already in 2014, and I never found a solution for it.




« Last Edit: November 19, 2017, 12:37:41 AM by Aversal »

Aversal

  • Posts: 3
  • Maggot Crusher.
    • View Profile
Re: Debug Assertion failure bug (?)
« Reply #2 on: November 25, 2017, 12:50:59 PM »
This time I actually succeeded in removing the error, somehow. The previous post was a false alarm, but this time everything is in order. I can tell, since the game closes normally, which it never did before during the error's lifetime.

I merely changed controllers. I used an USB-connected PC-controller before, but this whole thing got fixed after I started using a Dualshock 4 -controller.
I have to admit that I never tried to play the game while the controller was unplugged, but that might've worked out too. I would be nice since buying an expensive controller, especially if one already has some kind of a controller, might not be a good investment just to fix this game. It was for me, since I bought it for other reasons, but I digress.

As before, I hope this is of some help to someone, as the bug seems nearly impossible to fix otherwise.