Author Topic: Editor tilemap ressource error  (Read 3249 times)

KptnKook

  • Posts: 45
  • Immersive or DIE!!!!!
    • View Profile
Editor tilemap ressource error
« on: August 23, 2013, 12:39:16 PM »
 :o hey,

after reloading ressources, my default tilemaps gone missing, yet they are untouched at the same place. any level that i load now gives me an error message that i can continue, but displays all my tilemaps as white, as if they are not available. i don't know how to link the editor to the right asset folder. anyway i dont really know, why this error occurs, i cant even start a new map, the tiles are chooseable, but displayed plain white.

after reinstalling hammerwatch, error still there. starting editor new works, but after loading any game, there is an error and the ressources vanish.

here is the log:
Quote
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.FormatException: Input string was not in a correct format.
   at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)
   at TiltedEngine.SValue.ParseXMLNode(XElement node) in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\SValue.cs:line 197
   at TiltedEngine.SValue.ParseXMLNode(XElement node) in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\SValue.cs:line 186
   at TiltedEngine.ResourceBank.LoadBehavior(XElement root) in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\ResourceBank.cs:line 813
   at TiltedEngine.ResourceBank.LoadActor(XElement root, String name) in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\ResourceBank.cs:line 827
   at TiltedEngine.ResourceBank.LoadXML(String name) in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\ResourceBank.cs:line 170
   at TiltedEngine.ResourceBank.LoadModResources() in C:\Arbete\Programmering\C#\ARPGProj\trunk\Tilted Engine\TiltedEngine\ResourceBank.cs:line 85
   at TiltedEditor.TiltedEditorViewControl.LoadResources(String mod)
   at TiltedEditor.TiltedEditorForm.reloadResourcesToolStripMenuItem_Click(Object sender, EventArgs e)
   at TiltedEditor.TiltedEditorForm.SetMod(String mod)
   at TiltedEditor.TiltedEditorForm.openToolStripMenuItem_Click(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
...
« Last Edit: August 23, 2013, 01:48:18 PM by KptnKook »

Myran

  • Developer
  • Posts: 183
    • View Profile
Re: Editor tilemap ressource error
« Reply #1 on: August 24, 2013, 02:48:19 PM »
So you seem to have an actor with an incorrect xml file. If you want to make your own resources for your map you should put them in your maps folder, not in a assets folder where the game is.

KptnKook

  • Posts: 45
  • Immersive or DIE!!!!!
    • View Profile
Re: Editor tilemap ressource error
« Reply #2 on: August 24, 2013, 11:36:22 PM »
 ??? oh my. i messed up so much.

i actually realized that also... its related to the wrongly added new actor. it works now perfectly.
thank you for looking through!
« Last Edit: August 24, 2013, 11:42:45 PM by KptnKook »